Howto: PHP-FFMPEG avec un PHP custom.

Il y a quelques temps, j’ai cherché à installer PHP-FFMPEG au coté d’une version personnalisée de PHP, mais ce fut un échec. L’idée était de pouvoir utiliser une version PHP beaucoup plus récente que celle fourni par défaut dans la distribution (Ubuntu 8.04 et PHP 5.2.4 à l’époque).

Aujourd’hui, sous Ubuntu 12.04, j’ai à ma disposition PHP 5.3.10. Or la dernière version stable à ce jour est la 5.5.7. L’objectif n’est pas de courir après la dernière version sortie, mais d’utiliser une version pas trop vieille, et surtout encore maintenue. Il y a encore pas mal de version 5.2 qui traîne alors qu’elle n’est plus maintenue.
Lire la suite